Server Hoster change and some bug fixes and Design changes
Resolved
May 6, 2026 at 6:00pm UTC
Maintenance ended
Affected services
Created
May 6, 2026 at 1:00pm UTC
We are writing to inform you that due to the current host’s insufficient and unreliable performance over the past months, we have decided to change our host. Additionally, we will be enhancing our website and fixing numerous bugs to improve your experience.
The maintenance work is scheduled to take place from 3:00 PM to 6:00 PM German time. During this period, all services will be unavailable. We apologize for any inconvenience this may cause and appreciate your understanding.
We will keep you updated on our status page and provide further information as needed. Thank you for your patience and support.
Affected services